Results 1 to 7 of 7

Thread: 300 TDi Lift Pump Arm Broken!

  1. #1
    Apprentice Rich/Elaine's Avatar
    Join Date
    4th Jun 2010
    Location
    Woody Whitwick, Leicestershire
    Age
    43
    Posts
    347
    Reviews
    Read 0 Reviews

    Question 300 TDi Lift Pump Arm Broken!

    Today I replaced the old Lift Pump with a new one, but instead of running well the engine suffered fuel starvation going up hill, so I took the pump back off to investigate.... the arm had broken off!!! Tried to get it out of the engine with a telescopic magnet, and its head came off!!! I kid you not. Managed to get the magnet back out using long nose pliers, but the arm was just too far in. I taped the magnet back to the telescopic bit, and tried again.... *tinkle* the arm fell down!!
    Here's where I need help, would it have dropped straight into the sump, or is there somewhere else for it to go?

    Thanks in Advance.

  2. #2
    Defender of the Forum. TEMPL4R's Avatar
    Join Date
    14th Oct 2005
    Location
    Fleetwood, United Kingdom
    Posts
    24,110
    Reviews
    Read 0 Reviews

    Default Re: 300 TDi Lift Pump Arm Broken!

    It should have fallen into the sump as there is no ladder like a 200 has.

    It might be easier to take the vacuum pump off, the hole is bigger isn't it?

    Otherwise sump off.

    Chris
    ........Such are they, whom God chooses for Himself, and gathers from the furthest ends of the Earth, servants from among the bravest, in Israel, to guard watchfully and faithfully, His sepulchre and the Temple of Solomon, sword in hand, ready for battle.
    YCHJCYA2PDTHFH and PhD Hons Drvl Cleckheaton and Grand Master of the Forum Lodge of Enlightenment

    Everyone is entitled to their opinion, the trouble is, yours is ridiculous.

  3. #3
    Apprentice Rich/Elaine's Avatar
    Join Date
    4th Jun 2010
    Location
    Woody Whitwick, Leicestershire
    Age
    43
    Posts
    347
    Reviews
    Read 0 Reviews

    Default Re: 300 TDi Lift Pump Arm Broken!

    Wow, that was a quick response! Cheers Chris, I'll let you know how it goes...

    E.

  4. #4
    Apprentice Rich/Elaine's Avatar
    Join Date
    4th Jun 2010
    Location
    Woody Whitwick, Leicestershire
    Age
    43
    Posts
    347
    Reviews
    Read 0 Reviews

    Default Re: 300 TDi Lift Pump Arm Broken!

    Found it!
    The sump's back on now. Somehow I don't think we'll be buying another Brit Parts lift pump...

    Thanks again,
    Elaine.

  5. #5

    Default Re: 300 TDi Lift Pump Arm Broken!

    Quote Originally Posted by Elaine J View Post
    Found it!
    The sump's back on now. Somehow I don't think we'll be buying another Brit Parts lift pump...

    Thanks again,
    Elaine.
    Send it back and give em what for though!! They deserve to know what tat they make and how much of your time they wasted with you fixing problems their rubbish caused! It really annoys me that they won't compensate you for your time on things like this! Imagine if it were a clutch and you needed the car for work the next day...

    Glad its sorted without too much major hassle though

  6. #6
    Apprentice Rich/Elaine's Avatar
    Join Date
    4th Jun 2010
    Location
    Woody Whitwick, Leicestershire
    Age
    43
    Posts
    347
    Reviews
    Read 0 Reviews

    Thumbs up Re: 300 TDi Lift Pump Arm Broken!

    If we'd have known that Craddocks would be sending us a Brit Part one we'd have ordered from elsewhere...
    Don't worry, they'll be getting a phone call tomorrow, because like you said it could have been a major inconvenience.

    Fitting a Delphi in a bit,
    Elaine&Rich.

  7. #7

    Default Re: 300 TDi Lift Pump Arm Broken!

    Elaine, I feel your pain (I'm having to replace a cylinder head gasket for the second time in a week). I'm so glad you managed to retrieve things without too much trouble. Good luck with getting everything sorted.

    Sarah
    1995 Defender 110 CSW 300Tdi; 1997-now managed to hang on to this one
    1995 Defender 110 CSW 300Tdi; 1997-1997 stolen after three months
    1968 IIA 109" 10 seat station wagon; 1989-2003 but still in the family

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power steering pump. Is this broken?
    By blackfiesta123 in forum Land Rover Defender
    Replies: 5
    Last Post: 16th Sep 2013, 12:21
  2. replacing a lift pump with an electric pump on a 300 tdi
    By WINGNUT1 in forum Discovery Series I and II
    Replies: 12
    Last Post: 17th Jan 2013, 22:52
  3. Wanted: broken injection pump
    By profqwerty in forum Land Rover Defender
    Replies: 1
    Last Post: 5th Sep 2011, 18:15
  4. lift pump
    By jointer in forum Discovery Series I and II
    Replies: 5
    Last Post: 17th Jun 2010, 23:25
  5. Lift pump
    By Alice in forum Land Rover Defender
    Replies: 7
    Last Post: 11th Dec 2006, 17:03

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •