Results 1 to 3 of 3

Thread: Auto gearbox problems - solenoid 2?

  1. #1
    Trainee
    Join Date
    24th Aug 2007
    Location
    Co. Limerick, Ireland
    Posts
    70
    Reviews
    Read 0 Reviews

    Default Auto gearbox problems - solenoid 2?

    I have been having intermittent problems with my 2004 Discovery automatic gearbox. Initially it was the M & S lights flashing and being in limp mode of 3rd gear. Have had LR garage look at it twice - cleared faults which indicated problems with solenoid 2. Now it has stopped flashing the lights but seems change up from first when cold, but will not change down below 3rd once I have gone a couple of miles.
    The operation of the gearbox is otherwise really smooth.

    The LR garage checked the external wiring looms - nothing found and no change, still a fault indicating on solenoid 2. I have had a discussion with an auto gearbox specialist in Dublin and they suggest that the internal loom or the solenoid should be changed, this can be done readily by dropping the sump. This specialist company is nowhere near me and can't do anything for a couple of weeks.

    Questions:
    1. Does changing the solenoid sound like the possible fix?
    2. Where can I get the solenoid as a spare part?
    3. Should I have a go at it myself (I have an excellent mechanic from work that could help me)

    Any advice gratefully received.

    Thanks, Johnny

    PS I see someone else on the forum is asking about whether to get anAuto or Manual 2004. At the moment I wish I had a manual.

  2. #2
    Engineer thebiglad's Avatar
    Join Date
    28th Oct 2007
    Location
    Central France
    Posts
    3,128
    Reviews
    Read 0 Reviews

    Default Re: Auto gearbox problems - solenoid 2?

    Quote Originally Posted by Johnny H View Post
    I have been having intermittent problems with my 2004 Discovery automatic gearbox. Initially it was the M & S lights flashing and being in limp mode of 3rd gear. Have had LR garage look at it twice - cleared faults which indicated problems with solenoid 2. Now it has stopped flashing the lights but seems change up from first when cold, but will not change down below 3rd once I have gone a couple of miles.
    The operation of the gearbox is otherwise really smooth.

    The LR garage checked the external wiring looms - nothing found and no change, still a fault indicating on solenoid 2. I have had a discussion with an auto gearbox specialist in Dublin and they suggest that the internal loom or the solenoid should be changed, this can be done readily by dropping the sump. This specialist company is nowhere near me and can't do anything for a couple of weeks.

    Questions:
    1. Does changing the solenoid sound like the possible fix?
    2. Where can I get the solenoid as a spare part?
    3. Should I have a go at it myself (I have an excellent mechanic from work that could help me)

    Any advice gratefully received.

    Thanks, Johnny

    PS I see someone else on the forum is asking about whether to get an Auto or Manual 2004. At the moment I wish I had a manual.

    Hi Johnny, this is how I would approach this problem:

    1. First check the oil level in the gearbox, using the correct procedure; top-up as necessary;

    If the oil level isn't correct it can cause all sorts of mechanical malfunctions.

    2. Put the battery on charge for at least 12 hrs.

    If there is any doubt whatsoever about the battery performance it can cause the 'M&S' lights to light up. This is caused by insufficient electrical power being available during the engine starting procedure.

    These 2 items will cost you nothing, you can do them at home and may well fix your problems. If they don't at least you have a baseline from which to work.
    Had loads though!

    2010 Triumph Bonneville T100

  3. #3
    Engineer Jimbob292's Avatar
    Join Date
    26th Apr 2009
    Location
    Dubai, UAE
    Posts
    1,314
    Reviews
    Read 0 Reviews

    Default Re: Auto gearbox problems - solenoid 2?

    You might want to try a transmission flush, it might just be a little varnish on the solenoid valve, i use this stuff http://www.lubegard.com/~/C-178/LUBE...smission+Flush then fill back up with fresh ATF.
    Discovery 3.9 V8 FXi

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Disco 2 ,2002 ,td5,auto :problems with auto transfer box
    By dpetro in forum Discovery Series I and II
    Replies: 5
    Last Post: 6th May 2012, 15:46
  2. P38 auto gearbox problems
    By robinwr in forum P38 forum
    Replies: 5
    Last Post: 15th Dec 2011, 13:48
  3. Auto gearbox problems
    By rsajon in forum Discovery Series I and II
    Replies: 11
    Last Post: 4th Jun 2011, 17:36
  4. p38 dhse auto gearbox problems
    By roryj in forum P38 forum
    Replies: 1
    Last Post: 11th Feb 2010, 12:07
  5. Auto Gearbox problems
    By derrick1946 in forum Land Rover Discovery
    Replies: 13
    Last Post: 7th Jun 2009, 11:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •