Results 1 to 8 of 8

Thread: Brake lights not working, fuses ok, bulbs ok ??

  1. #1

    Default Brake lights not working, fuses ok, bulbs ok ??

    Hi there,

    My husband is desperately trying to fix our brake lights so we are safe on the road ! The high tail gate is working so is the LH one at the bottom but none of the other. Reverse lights okay also. He checked bulbs and fuses, even tried replacing bulbs made no difference.

    Help quick ? thanks !

  2. #2
    Mechanic Shambolic's Avatar
    Join Date
    19th Mar 2009
    Posts
    695
    Reviews
    Read 0 Reviews
    Blog Entries
    1

    Default Re: Brake lights not working, fuses ok, bulbs ok ??

    So you have one lower brake light not working then?
    It's a case of checking the bulb fitting to see if power is reaching it, and also that it is earthed properly, then tracing the wires back if it isn't.
    Give it a clean/spray with electrical contact cleaner or wd40 and that might solve the problem.
    Proud member of the YCHJCYA2PDTHFH club.

  3. #3
    Mechanic Shambolic's Avatar
    Join Date
    19th Mar 2009
    Posts
    695
    Reviews
    Read 0 Reviews
    Blog Entries
    1

    Default Re: Brake lights not working, fuses ok, bulbs ok ??

    Proud member of the YCHJCYA2PDTHFH club.

  4. #4

    Default Re: Brake lights not working, fuses ok, bulbs ok ??

    Quote Originally Posted by Shambolic View Post
    So you have one lower brake light not working then?
    It's a case of checking the bulb fitting to see if power is reaching it, and also that it is earthed properly, then tracing the wires back if it isn't.
    Give it a clean/spray with electrical contact cleaner or wd40 and that might solve the problem.
    Sorry perhaps i've confused you . I"ve attached a picture to clarify things showing what works what doesn't
    My hubby said that he tried to press the fog light button on, and all the break lights were working then. He reckons it's the break switch... Do you think so, and if so where is that located is it easy to fix or should the car be taken into a garage ? thanks backlights.jpg

  5. #5
    Mechanic Shambolic's Avatar
    Join Date
    19th Mar 2009
    Posts
    695
    Reviews
    Read 0 Reviews
    Blog Entries
    1

    Default Re: Brake lights not working, fuses ok, bulbs ok ??

    Quote Originally Posted by landyooh View Post
    Sorry perhaps i've confused you . I"ve attached a picture to clarify things showing what works what doesn't
    My hubby said that he tried to press the fog light button on, and all the break lights were working then. He reckons it's the break switch... Do you think so, and if so where is that located is it easy to fix or should the car be taken into a garage ? thanks backlights.jpg
    The brake light switch is located directly above the brake pedal, it can be awkward to reach but no tools are required to change it, as it simply twists on/off and you disconnect/re-connect the multi plug connector.
    I'd be double checking the bulbs and earths first (fog and offside brake light).
    Also check that all bulbs in use are the correct voltage and types.
    Proud member of the YCHJCYA2PDTHFH club.

  6. #6
    Consultant Llanigraham's Avatar
    Join Date
    18th Mar 2006
    Location
    Llanidloes, Powys
    Posts
    6,168
    Reviews
    Read 0 Reviews

    Default Re: Brake lights not working, fuses ok, bulbs ok ??

    Re Fog light?
    Can you confirm which country you are in, please?
    AKA : THE FAT CONTROLLER
    MSA Radio: WORCESTER 1




  7. #7
    Mechanic Shambolic's Avatar
    Join Date
    19th Mar 2009
    Posts
    695
    Reviews
    Read 0 Reviews
    Blog Entries
    1

    Default Re: Brake lights not working, fuses ok, bulbs ok ??

    Hi Graham,
    I'm assuming they are in the UK, as although the rear reg' number and wheel cover info' have been obscured, I'd hazard a guess that the window sticker is a Hunters of Guildford, Surrey. Obviously a FL1 facelift 2003-2006, td4.
    Strange issue with the rear lamps though?
    Proud member of the YCHJCYA2PDTHFH club.

  8. #8

    Default Re: Brake lights not working, fuses ok, bulbs ok ??

    If some of the brake lights are working the the brake switch is ok.
    Sounds like it could be a bad earth, odd things happen when power has to take a path to earth via a different cicuit.
    You dont say if the tail lights and indicators work or not, the brake/tail light bulb is dual filament so if the tail light works, it proves the earth is ok.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brake lights not working
    By JASPLUMPTON in forum Discovery Series I and II
    Replies: 4
    Last Post: 10th May 2012, 20:21
  2. fuses keep blowing and lights aren't working
    By defending the90 in forum Land Rover Defender
    Replies: 9
    Last Post: 6th Jan 2011, 08:57
  3. Brake Lights Not Working
    By bobspart in forum Discovery Series I and II
    Replies: 4
    Last Post: 30th Nov 2010, 12:17
  4. brake lights not working
    By tealman in forum Land Rover Discovery
    Replies: 3
    Last Post: 20th Sep 2010, 09:04
  5. Fuses/lights not working
    By BIGTUG in forum Land Rover Defender
    Replies: 2
    Last Post: 7th Jan 2009, 20:49

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •